Archive

Posts Tagged ‘Form Services 2010’

Security Validation Issue – Form Services issue with SP1+June 2011 CU (Release 2) #in #SP2010 #SharePoint #MSProject #ProjectServer

July 20, 2011 10 comments

We are testing Service Pack 1 heavily in my project that I have talked about on this blog many times.

One of the features of our implementation is a number of developed InfoPath forms.  We found one issue previously that required a hotfix and it looks like SP1 and June 2011 CU (Release 2) has introduced another.

My colleague Paul Busby has mentioned it here:

http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010customization/thread/6d5ffcb6-7563-4234-9282-e767b56b97b2

and another user has also confirmed the issue.

I shall be sending the details below to Microsoft through our partner support and hopefully we can get a resolution.

 

Scenario:

  • Form Services
  • Administrator Approved Form
  • Server Version: 14.0.6106.5002 (Office 2010 SP1 + June 2011 CU – Release 2)
  • Client Version: 14.0.6023.1000 (Office 2010 SP1)
  • NB: June 2011 Cumulative Update does not include updates for InfoPath 2010
  • Microsoft June 2011 Cumulative Update for Office 2010 Client Applications – KB2259686: http://support.microsoft.com/kb/2259686/en-us

The form has two views:

  • View one has a people picker
  • View two is blank

The form is uploaded via Central Administration and activated to a site collection

A form library is created and the associated content type is attached

Upon creating a new form, the form loads

Screenshot 1

When the user switches views in the form, a Security Validation Error occurs:

Screenshot 2

Further Details:

  • We have discovered that it appears to happen when switching to or from a view that contains a people picker field.
  • Turning off security validation, allows the form to continue to work, but this is not something we want to go live with
  • This issue has been found on a client DEV and TEST environment as well as a newly installed RTM machine upgraded to SP1 + June 2011 CU Release 2

SharePoint 2010 Log Details (specific details in red):

07/20/2011 13:54:03.85           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     Monitoring                               nasq     Medium            Entering monitored scope (Request (POST:http://vm482:80/_layouts/FormServer.aspx?XsnLocation=http://vm482/FormServerTemplates/SP1SecurityValidationTest_Published.xsn

&SaveLocation=http%3A%2F%2Fvm482%2FSP1SecurityValidationTest&ClientInstalled=true&Source=http%3A%2F%2Fvm482%2FSP1SecurityValidationTest%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1))    

07/20/2011 13:54:03.85           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     Logging Correlation Data          xmnv   Medium            Name=Request (POST:http://vm482:80/_layouts/FormServer.aspx?XsnLocation=http://vm482/FormServerTemplates/SP1SecurityValidationTest_Published.xsn

&SaveLocation=http%3A%2F%2Fvm482%2FSP1SecurityValidationTest&ClientInstalled=true&Source=http%3A%2F%2Fvm482%2FSP1SecurityValidationTest%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1)      5c0ca3e0-a782-4691-9a79-b2e163e3f0e9

07/20/2011 13:54:03.85           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     Logging Correlation Data          xmnv   Medium            Site=/   5c0ca3e0-a782-4691-9a79-b2e163e3f0e9

07/20/2011 13:54:03.91           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     Web Controls                          cm8z    Medium            Failed to get SPGroupName from GroupID. Error Message: Group cannot be found.  Callstack:    at Microsoft.SharePoint.SPGroupCollection.GetByID(Int32 id)     at Microsoft.SharePoint.WebControls.PeopleEditor.set_SharePointGroupID(Int32 value).           5c0ca3e0-a782-4691-9a79-b2e163e3f0e9

07/20/2011 13:54:03.91           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     General                        8kh7    High    The security validation for this page is invalid. Click Back in your Web browser, refresh the page, and try your operation again.           5c0ca3e0-a782-4691-9a79-b2e163e3f0e9

07/20/2011 13:54:03.91           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     Runtime                                   tkau      Unexpected     System.Runtime.InteropServices.COMException: The security validation for this page is invalid. Click Back in your Web browser, refresh the page, and try your operation again.    at Microsoft.SharePoint.Library.SPRequestInternalClass.ValidateFormDigest(String bstrUrl, String bstrListName)     at Microsoft.SharePoint.Library.SPRequest.ValidateFormDigest(String bstrUrl, String bstrListName)          5c0ca3e0-a782-4691-9a79-b2e163e3f0e9

07/20/2011 13:54:03.91           w3wp.exe (0x10CC)                           0x11BC           SharePoint Foundation                     Monitoring                               b4ly      Medium            Leaving Monitored Scope (Request (POST:http://vm482:80/_layouts/FormServer.aspx?XsnLocation=http://vm482/FormServerTemplates/SP1SecurityValidationTest_Published.xsn

&SaveLocation=http%3A%2F%2Fvm482%2FSP1SecurityValidationTest&ClientInstalled=true&Source=http%3A%2F%2Fvm482%2FSP1SecurityValidationTest%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1)). Execution Time=66.2620528586734            5c0ca3e0-a782-4691-9a79-b2e163e3f0e9

Auto height plain text box issue fixed in InfoPath / Form Services 2010 #in #SharePoint #SP2010

A quick post to say that the InfoPath / Form Service 2010 issue I was having at one of my clients has now been fixed and is included as part of the SharePoint 2010 – April 2011 Cumulative Update.

My description of the issue can be found here: http://ghamson.wordpress.com/2010/10/17/form-services-infopath-2010-bug-found-in-multi-line-plain-text-boxes/

Microsoft KB Articles

I would also like to take this opportunity to thank the Microsoft support and product teams in working with us to detail the issue and come to a resolution.  We are testing the go live environment with April CU 2011 as I write this and the fix will dramatically improve the UI for the custom forms that we have developed.

Form Services / InfoPath 2010 Bug found in Multi-line Plain Text boxes

October 17, 2010 9 comments
Just a quick blog to let users know of an issue I have found during my current project involving InfoPath Form Services (This only occurs in the web and not in the client).  I have logged this with Microsoft and am awaiting response / resolution.

I will update this post when I have closure of the issue.

Scenario:

An InfoPath Form created in Microsoft InfoPath Designer 2010 and is installed as an Administrator approved template.

  • Form Control: Text Box
Display:

  • Read-only – No
  • Enable spelling checker – Yes
  • Enable AutoComplete – Yes
  • Multi-line – Yes
Size:

  • Height: Auto
Compatibility Settings:

  • Form Type: Web Browser Form (2010)
Issue:

  • Browser: Internet Explorer 7, 8, Google Chrome
When running the Form in the web and a user types into the multi-line text box; after 20 characters the text box gets bigger by 1 row.

On evaluation using the IE8 development toolbar.  It would appear that the control is rendered as a <textarea> HTML element and JavaScript runs on the 22nd character and adds 1 to the “rows” attribute of the <textarea> element.

For example:

123456789012345678901 – Textarea row = 1
  • Image Before:
1234567890123456789012 – Textarea row = 2
  • Image After:
This is regardless of the width of the Text Box (Multi-line) control on the InfoPath form.

  • Browser: Firefox 3.6.10
A different issue occurs on the same control in the same scenario within Firefox.

When typing a paragraph until the end of the textbox size, the <textarea> element does not auto expand until the user presses return.

Follow

Get every new post delivered to your Inbox.

Join 1,691 other followers

%d bloggers like this: