Archive

Posts Tagged ‘SP2016’

#SP2016 Technical Preview–testing the new stuff–part 1–Document Libraries–Accessibility

September 8, 2015 Leave a comment

As part of the new features of SharePoint 2016 On-Premise there are some bold promises that have been causing issues with my customers for a long time that are supposedly fixed.

I intend to create some post that tries out these known limitations and see the results.

For this, I have created a standard Team Site out of the box and not turned on any features that are not turned on by default (yet…).

Here is a quick summary of what I shall be looking at for the next set of posts:

  1. Document Library Accessibility (https://msdn.microsoft.com/en-us/library/Mt346121(v=Office.16).aspx#doclib)
  2. Durable Links
  3. File names – expanded support for Special Characters (https://msdn.microsoft.com/en-us/library/Mt346121(v=Office.16).aspx#file)
  4. Image and Video Previews within a document library (https://msdn.microsoft.com/en-us/library/Mt346121(v=Office.16).aspx#preview)
  5. Large file support (https://msdn.microsoft.com/en-us/library/Mt346121(v=Office.16).aspx#largefile)
  6. Open Document Format (ODF) support (https://support.office.com/en-us/article/Set-Open-Document-Format-ODF-as-the-default-file-template-for-a-library-bf30a61d-1601-486e-8fa2-924bc5ea303e)

That’s quite a lot for a single post, so this may end up being a multi part situation, but you have probably already gathered, I tend to write these blogs as I try things out.  So without further ado…

1. Document Library Accessibility

For this test I am using the standard Shared Documents, document library that is created with the team site by default.

Accessibility it always a hot topic for me as I used to work a lot in the education and charity / not for profit sectors when I was back in the UK.  Accessibility mattered especially when working with the blind.

Keyboard shortcuts are provided for the following document tasks according to the documentation provided by Microsoft.  Let’s give them a go:

  • Alt + NNew – This worked with no issues and in a standard document library, I got the Upload Document dialog.  This is dependent on the behavior of the default content type on the library.  (Site Pages creates a new Wiki Page for example)
  • Standard Document Library Example:

01 - Alt+N

  • Site Pages Example:

02 - Alt+N

  • Alt + EEdit – In IE11, I could not get this to work as it kept invoking the edit menu in the browser.  Tried CTRL + E, CTRL + Alt + E with a document selected and not selected but to no avail.
  • Alt + UUpload – Same functionality as Alt + N in the Shared Document library.  Under the Site Pages library, it activated the upload dialogue.  So it is slightly different.
  • Alt + MManage
  • Alt + SShare  – Either having a document selected or not, this always highlighted and set focus on the Search Box for me
  • Alt + Y – Synchronization – Opened the One Drive for Business web dialog to start the sync
  • Sync Example:

02 - Alt+Y

This is the Technical Preview, so maybe it will change with the full release or perhaps I am not doing something right.  These tests were carried out with Accessibility mode turned on and off.  The results were the same in both cases.

So I have had this post going on an off for a couple of days now, so it will definitely be multi part.  Let’s get this one out there and we will work on Durable Links next time around.

Till the next time…

#SP2016 Technical Preview–SharePoint 2010 Workflows still available!

September 8, 2015 Leave a comment

So I am running a project internally at the moment about moving away from a vended product to a capability in Office 365 / SharePoint Online using out of the box functionality as much as possible (cost saving exercise) – The Oil & Gas industry is hitting hard times if you haven’t seen commodity prices lately!

Anyway, this interim / temporary solution requires me to send an email to an external user.

With the SharePoint 2010 workflow engine, you could do this with a standard SharePoint Designer workflow.

In SharePoint 2013 they essentially deprecated the SharePoint 2010 workflow engine and introduced a new Azure based version.

This newer workflow engine requires the user that you send an email to an authenticated user with Active Directory / Azure Active Directory.  This causes me an issue for my temporary solution in SharePoint Online!

 

Can Nintex Help?

 

I initially thought… perhaps Nintex Workflow for Office 365 Workflow can help?

Alas, it is based on the SP2013 Workflow engine, so no luck there…

(To be fair, you can’t really blame Nintex for supporting the current standard… I would do the same)

 

What are my options?

 

1. Add the external users to Azure AD – Not really an option in this case right now

2. Create a 2010 platform workflow with a single step – Email User.  Call this workflow from the 2013 workflow and hope it stays supported – For this temporary solution, this may work but we all know how temporary often becomes permanent.

3. Create my own code / action to call a web service and send the email – This would work but for this temporary no code solution, it feels overkill.  A good backup however, if the solution turns permanent.

4. Find a 3rd party product that can add actions.  PlumSail has a package: https://plumsail.com/workflow-actions-pack/.  $400 per year.  – This is also a good option but there is of course this gotcha!

There isn’t going to be a SharePoint Designer 2016.

http://blogs.technet.com/b/sharepointwarrior/archive/2015/05/13/sharepoint-2016-on-premises-update-ignite-recap.aspx

SharePoint Designer 2013 however still works.

 

Conclusions

 

Now that I have my newly installed SP2016 On-Premise environment and I can confirm that this is still currently available when you connect SharePoint Designer 2013 to a SP2016 On-Premise server.

image

I can also confirm that as of the time of writing, it is also still available in SharePoint Online.

So for this “temporary” project, this is likely the way we will go, knowing full well, it might go away at some point.

Stay tuned for more posts about SharePoint 2016 as I answer my own questions about the real business issues I face.

#SP2016 Technical Preview – installed…

September 6, 2015 Leave a comment

Part 2 of my mini blog posts as I install SP2016 Technical Preview over this Labor Day weekend.

We’re installed!  I chose Single Server Install right now as I have limited resources on my host and it is my intention to turn this into a DEV box for future App Model (Add In) projects.

SP2016 Install 3

Click Finish and Central Administration starts to load…

SP2016 Install 4

by all means send my info to the Customer Experience Program… it’s what this early access is all about!

Lastly, as you can see, Central Administration looks pretty familiar.  For this Single Server Install I shall kick off the configuration wizard and see which managed services it installs by default.

SP2016 Install 5

Stay tuned for the next post as I kick off this process and blog the results…

%d bloggers like this: